Website problems

Community news posted by the SSC staff.
Locked
User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Website problems

Post by SSCBen » Tue May 18, 2010 11:42 pm

We are aware that the website goes down often. I believe the problem stems from an incompatibility between a database abstraction layer we use and PHP 5. In a week or two I will recode the backend to avoid this problem.

Let me know here when the website goes down but the forum is still up.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Website problems

Post by SSCBen » Sat Jan 08, 2011 6:49 pm

This problem has persisted. I've contacted our host's support team. Perhaps they will have some ideas about how to solve the problem.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Website problems

Post by SSCBen » Sat Jan 08, 2011 7:00 pm

The downtime problem has been fixed temporarily. It was caused by something we were completely unaware of, but our host's support team knew the problem immediately when I described it.

The website may perform slower due to the temporary fix. A permanent fix is coming.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
martianshark
Posts: 689
Joined: Mon Jul 06, 2009 10:24 pm

Re: Website problems

Post by martianshark » Mon Jan 10, 2011 5:49 am

The main page works right now, but when I clicked on a link besides the home page, this came up:

Fatal error: Non-static method (null)::…À~ôeø[^]ÃÇD$() cannot be called statically in /home/virtual/site178/fst/var/www/html/scms/ADOdb/adodb.inc.php on line 199

Fredcompany
Posts: 198
Joined: Thu May 13, 2010 7:09 pm

Re: Website problems

Post by Fredcompany » Mon Jan 10, 2011 5:10 pm

And the main page is back down again (17:09 GMT)
I'm a dude

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Website problems

Post by SSCBen » Tue Jan 11, 2011 12:00 am

Thanks for pointing out problems. I didn't see them, but it sounds like perhaps the permanent fix isn't working right. (The temporary fix worked immediately, but can reduce performance.)

Please post again if you notice any problems.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
mysterio
Posts: 142
Joined: Wed Jul 14, 2010 11:18 pm

Re: Website problems

Post by mysterio » Tue Jan 11, 2011 12:25 am

Its not working again.

User avatar
C-A_99
Posts: 1502
Joined: Tue Aug 01, 2006 11:09 pm

Re: Website problems

Post by C-A_99 » Tue Jan 11, 2011 12:30 am

Looks like the downtime is shorter; I just accessed the home page sucessfully 4 minutes after the above post.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Website problems

Post by Specter » Tue Jan 11, 2011 8:20 pm

Don't know if it's my browser/internet being crappy right now, but the logo at the top of the forum and background image aren't loading.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
C-A_99
Posts: 1502
Joined: Tue Aug 01, 2006 11:09 pm

Re: Website problems

Post by C-A_99 » Tue Jan 11, 2011 10:18 pm

If all else fails, switch to another host. If the new host doesn't have problems, then this one wasn't worth your money. Although if you know other websites on the same host that never have problems, or if SSC has problems on another host, then it's definitely a problem with the system. (Which I still lack the know-how to assess.)

User avatar
martianshark
Posts: 689
Joined: Mon Jul 06, 2009 10:24 pm

Re: Website problems

Post by martianshark » Wed Jan 12, 2011 3:31 am

It's happening again.

User avatar
zeda.beta
Posts: 683
Joined: Sun May 03, 2009 10:49 pm

Re: Website problems

Post by zeda.beta » Thu Jan 13, 2011 11:54 pm

Still ongoing. And I'm not far along enough in MySQL to offer assistance.
I reject your reality and substitute my own.
Quack damn you.

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Website problems

Post by SSCBen » Fri Jan 14, 2011 6:47 pm

The problem is not related to MySQL. It apparently is related to APC, a PHP caching system. Disabling APC solves the problem immediately, but this is not advisable due to performance decreases. Allegedly upgrading APC should have solved the problem, but it does not appear to have done so.

Anyhow, I've contacted support again. Maybe they could try something else. Edit: Matt will check and post in this thread as necessary. Thanks Matt!

Edit again: It's not clear that other hosts would necessarily be better than Apis in this respect. I've been very satisfied with their work so far, so I don't intend to switch unless someone else wants to take over the head admin. position (in which case I'll keep the hosting, but use it for trettel.org exclusively).
Last edited by SSCBen on Mon Jan 17, 2011 7:46 pm, edited 1 time in total.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Website problems

Post by Specter » Fri Jan 14, 2011 7:36 pm

only thing that works as far as I've clicked is the home page. no other links work. either loading a blank page or that fatal error thing described before.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
martianshark
Posts: 689
Joined: Mon Jul 06, 2009 10:24 pm

Re: Website problems

Post by martianshark » Fri Jan 14, 2011 8:03 pm

The other pages are working for me right now.

Locked