Page 1 of 1

CPS Pump-problem

Posted: Wed Nov 17, 2010 11:28 pm
by -G-JiV-
Hi there, I have two CPSs(1000, 1500) where I got a problem with the pump. In case you pump slowly there is no problem, but if you pump quite fast the pump suddenly seems to block. May I have a problem with the first valve...

Do you know this problem? What can be done to fix it without opening the gun and sawing off to get to it?

Could you give me a clue where exactly the first valve begins and ends? I do not want to saw into it and creat even more damage...


Re: CPS Pump-problem

Posted: Thu Nov 18, 2010 12:22 am
by martianshark
Maybe the pressure release valve can't handle the pressure when you suddenly pump it hard. I don't really know.

Re: CPS Pump-problem

Posted: Thu Nov 18, 2010 8:17 am
by -G-JiV-
THis problem appear even at the first 5 pumps. It really only relates to the "suck - action" of the first valve. It does not make any difference whether you push the pump in fast or slowly, but speed at expanding the pump must be done slowly or it blocks and sucks no water...I will saw in now, wish me good luck^^

Re: CPS Pump-problem

Posted: Thu Nov 18, 2010 10:04 pm
by C-A_99
What do you mean that it blocks? I think I may have this issue (though minor) on my 2100, where the pump randomly gets stiff, and my old FF has also exibiting annoyingly strange behavior lately at the pump too. However, those are on the push action instead of the pull and I'm not even sure what the issue is myself.

Before sawing anything, you want to know for sure that one or both check valves are actually the problem. Even then, its unlikely that you'll be able to fix something by sawing it open. Maybe there's debris clogged before the first check valve; make sure all that is out of the way.

Describe your problem further before sawing. There's not much that can be done in the internals if at all.

Re: CPS Pump-problem

Posted: Thu Nov 18, 2010 10:14 pm
by cantab
See if the problem is still present with the reservoir cap unscrewed. The fault could perhaps be there instead of in the pump's valves. Bit of a long shot, but it could explain the problem and if it is the case, it should be fixable without opening up the blaster.

Re: CPS Pump-problem

Posted: Thu Nov 18, 2010 10:50 pm
by -G-JiV-
Thanks for help, but I was already able to fix it myself :)

I carefully saw before the valve and after it, so I could get the valve out. First I cleaned it inside there. Then I polished the rubber(which closes and opens) and the valve-pipe inside a bit, so it got a bit bigger, therefore easier in moving. Next thing was to over-expand the spring, it is now 100% longer than it was before, therefore it got much more power. I put everything back in, carefully glued everything together and yea, the "suck-action" just works great!
Next problem was that the second valve was also not in good working order. Again I saw off the pipe a bit before the valve begins. At this valve I only had to saw 1 time, not 2 times, because you have enough access to it. Same thing again, polished, cleaned, and spring over-expanded, so it has 100% more power.Glue together and finished.

I must point out I never got such a smooth and quiet pump. Sliedes very easy and quiet, not much power needed. Also works great when pumping very fast, so not even fixment but improvement I would say :D

Ok, problems solved, thanks for your help, although I read this article some hours after I finished work :D

Re: CPS Pump-problem

Posted: Thu Nov 18, 2010 11:59 pm
by C-A_99
I should note that epoxy putty may be the fastest and easiest way to put it back together, but then again, people have had bad experiences with it and it probably doesn't work on a large scale. Either way, as long as the glue seals and holds pressure and is spread well, it should be fine, though I personally would add an improvised coupling piece (such as cutting out a small part of a metal sheet and bending it) to help keep it together structurally.

This may possibly be the culprit on some blasters I've worked with (including a Nerf blaster), or it may not. I guess it may be worth a look.