Storm 700 pistol

Repairs to water guns. Please put repair topics in this forum so that people do not have to sort through so many topics when looking for a repair. If a fix is included in the topic, please add (Fixed) before the topic title to indicate so.
Locked
User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Storm 700 pistol

Post by Specter » Mon May 14, 2007 5:31 am

i have a storm 700 pistol from a while back. i have had many others but they have broken and have been thrown out. me and my brother both had the xp90 pulse(bad model due to flaws), i had the xp-70? i think it was (i remember it being yellow and blue if thats the correct model), and many others i cant remember; well anyway back to topic. this is basically like a sidearm/secondary pistol gun. this is my most recent gun and use it occasionally during the summer. but somehow a really small stone or something got in the "barrel" and it has trouble shooting, for example sometimes i can get it to shoot fine and then it will start to make a spray sort of thing. well i don't know if it can be fixed, maybe at the beginning of summer vacation I'll think of it. but i am a bit afraid to take the thing apart for some reason(maybe afraid that ill mess something on the inside up). give me some suggestions on how to approach this project, and maybe I'll get some pics and/or video at the beginning of the summer as i am too busy with the end of school/getting up on missed schoolwork/getting ready for exams, so give me some suggestions and ill look into this.

thanks. you guys are a great help with this stuff.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Mon May 14, 2007 10:28 pm

any suggestions please? i would like to fix this(if possible) to use it without interruption. its not a great gun but it can be fun.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Fri May 18, 2007 12:19 am

my soaker has a mildewey smell in it. is it ok to shoot soapy water thru it to clean it out? and i have a typo in my title its a storm 600 not 700.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Fri May 18, 2007 1:51 am

I know pretty much nothing about Storm guns, but I'll try to help...sorry for taking a while. :)

Ben wrote:give me some suggestions on how to approach this project,

This should be your attitude: "Well, there's nothing to lose!" Face it, the gun's broken...so you can't do any harm. At best, the gun will be fixed. At worst, the gun stays broken and useless.

After you've opened up a water gun, you'll be much more inclined to do so afterwards. It's fun. :)

Basically, just unscrew all the screws, and maybe tape them onto the plastic shell next to where they go so that you don't lose them. I can't really help you with regards to how to fix the problem, but pictures and an internal diagnosis could help.

Good luck! :cool:

EDIT: Soapy water should be fine, but maybe you'll want somebody else's word for it. I don't really know. But I think the internals are tough enough. Take a look at AMDAthlon's repairs to see all the stuff he had to use to clean out his soakers - and I think they were fine afterwards. Look at his description of the third repair - 6 molar hydrochloric acid inside the gun to clean it up. So even if you were using an acid and not a basic soap, I wouldn't be too worried.

Weird how you can remember things from ancient threads...

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Fri May 18, 2007 2:04 am

SilentGuy wrote:I know pretty much nothing about Storm guns, but I'll try to help...sorry for taking a while. :)


This should be your attitude: "Well, there's nothing to lose!" Face it, the gun's broken...so you can't do any harm. At best, the gun will be fixed. At worst, the gun stays broken and useless.

After you've opened up a water gun, you'll be much more inclined to do so afterwards. It's fun. :)
.



well its not broken, so I am a bit afraid to mess something up in the process of ""fixing" it. all the problem is, is that there is a small stone or something stuck in the "barrel" and it just is annoying because it sometimes sprays instead of shooting a stream. I'll probably jsut have to try taking the thing apart and try removing the stone or whatever it is. the other thing is trying to get around the electonics. (theres a red led that lights up the stream when shot, if theres batteries in the gun)

to clean it out, since i dont have access to that type of acid, is bleach water, or ammonia feasable? i know i cant use them both together because it creates lethal chlorine gas haha
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Fri May 18, 2007 2:13 am

Well then, all I can say is to open it up anyway. Not as much motivation I guess. I can say "it'll be fine" all I can, but I know it's hard to believe... :cool:

So, it's your choice if you want to open it. (I would.)

Can you actually see the stone? Also, how concerned are you about the electronics? In the modifications forums here at SSC, I had a recent topic about opening the Orca - the electronics don't really get in the way. Just take apart the two halves of the case slowly, in case wires do go from one side to the other.

Take a look at a picture of Storm 500 internals: http://www.sscentral.org/gallery/internals/storm500.php

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Fri May 18, 2007 2:48 am

thanks i think that may help a bit. my gun is quite a bit bigger than that one though. the part where the stone is, is that orange and clear part by the front. it doesnt look like that part opens up so if i can get the stone to the hole where the water comes out, i can use small needle nose pliers to get it out.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Sat May 19, 2007 1:08 am

im just going to go thru the process of fixing it. I'm doing it now to get it over with. I'll take pictures in the process and post them later.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Sat May 19, 2007 1:43 am

Im having a bit of a problem getting it apart, i got all the screws out, but the trigger/handle area wont come apart. the front and everything comes apart but the handle part wont.

Screws out:
Image

top view of trying to open:
Image

bottom view of handle/trigger not opening:
Image
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sat May 19, 2007 2:08 am

If you haven't done so already, try removing the cover to the battery case and then see if there's a case screw in there. It might even be underneath the batteries or a sticker. You're doing well so far though! :)

Also, in the future it would be nice if you could edit posts that are only a few hours old to add information. Thanks. :cool:

Good luck with the rest of the repair! Would you mind if these pictures were used in the next SSC site update?

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Sat May 19, 2007 2:22 am

no i don't care, you can use my pics. and i finally got the rest of it open. i think what they did whats glued the case shut around the handle and trigger so i pryed it open with a really small screwdriver. heres pics , sorry the internals came out bad with and without flash haha:

Open view:
Image

Internals:
Image

another internals without flash :
Image

i didnt think that the insides could get so dirty, haha. i found a dead spider and a couple other bugs.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Sat May 19, 2007 2:58 am

i have a small problem. i found where the small stone are, but my needle nose pliers are just a bit to big to get it. if they were a bit slimmer and longer i could. in this pic is the tube that goes from the tank to the "barrel", theres these 2 screw cap type things at the 2 elbows, i can unscrew them, but the tube doesnt come off. i don't want to cut it, do you think i can try prying it off with the small screwdriver? its the only thing keeping the stone from coming out.

heres pic:

Image
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sat May 19, 2007 3:13 am

Nice pics. :cool:

I've seen the flexible tubing with the screw parts on my Orca. If you want, see what you can do with the tube, but I'll take a look at my water gun and see how to get the pieces apart.

Glad to hear you've found the stones. Maybe you could use tweezers/forceps to pull the stones out...just a thought.

It looks like the flexible tube was pushed over a hose barb - basically a hollow, rigid tube. The screw pieces are then screwed on and tightened to stop the flexible tube from being blown off the tube barbs. I'm thinking that if you remove the screw protectors thingies, you can just pull the flexible tube off the barb.

I'll take a look though.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Post by Specter » Sat May 19, 2007 3:21 am

SilentGuy wrote:Nice pics. :cool:

I've seen the flexible tubing with the screw parts on my Orca. If you want, see what you can do with the tube, but I'll take a look at my water gun and see how to get the pieces apart.

Glad to hear you've found the stones. Maybe you could use tweezers/forceps to pull the stones out...just a thought.

It looks like the flexible tube was pushed over a hose barb - basically a hollow, rigid tube. The screw pieces are then screwed on and tightened to stop the flexible tube from being blown off the tube barbs. I'm thinking that if you remove the screw protectors thingies, you can just pull the flexible tube off the barb.

I'll take a look though.



I tried just pulling it off but its reallly tight. maybe it was glued on or something? But anyway yea, Im a bit tired now, (and hungry), so im going to finish this tomorrow or something. I also dont have good pair of tweezers and i dont have forceps.

thanks for trying to help.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

Locked