CPS 1000 pump leak

Repairs to water guns. Please put repair topics in this forum so that people do not have to sort through so many topics when looking for a repair. If a fix is included in the topic, please add (Fixed) before the topic title to indicate so.
User avatar
MilkMan
Posts: 310
Joined: Fri Apr 30, 2004 12:00 pm

CPS 1000 pump leak

Post by MilkMan » Sat May 06, 2006 8:26 pm

I just took my CPS 1000 out today to test it out for the summer and I noticed that is has a semi-considerable pump leak. When I pump it, water leaks out the pump and it starts dripping while also leaving the pump shaft damp. I think its always had this problem but it used to be very mild. It is much worse than it was last summer. Please help.
"Anything with a nozzle and a pump is good enough for me." <--------------- Same lying signature 3 years and counting!

User avatar
m15399
Posts: 224
Joined: Sat Oct 15, 2005 1:54 am

Post by m15399 » Sat May 06, 2006 10:12 pm

Take the pump out of the shaft and look at the oring. If it's in good condition, you may able to wrap a few layers of electrical tape around the shaft and stick the oring back on to fix it. The elctrical tape should make the oring fit the shaft better. If the oring is worn out or torn or something, you will probably have to replace it.

Could you take a picture of the pump? I'm not sure what kind of seal it is (I'm guessing oring, though).

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sun May 07, 2006 3:10 am

Definitely follow the age-old advice: instead of pushing it, open it up. Taking a picture could help too.

I'm going to be gone for a week, so your problem will probably be solved by then...

You could try to lightly pump it with the case open--that would help identify the actual weakness.

User avatar
blub man
Posts: 33
Joined: Tue May 09, 2006 8:50 pm

Post by blub man » Thu May 11, 2006 6:31 pm

I had exactly the same problem. Look around for some silicon grease (or silicon lubricon grease) , if you find some, spred LOADS around the O-rings and the shaft theyre in, its works a treat, and lubricates your pump. ;)
Who cares what temperature it is...GET SOAKED TODAY

Blub manImage

User avatar
joannaardway
Posts: 855
Joined: Mon Feb 20, 2006 10:04 pm

Post by joannaardway » Fri May 12, 2006 12:32 pm

Yes, Silicon grease is good, but it is not the ultimate solution to these things - it could be a different problem with similiar symptoms.

Never say "I had the exact same problem" - say "I had a problem rather like that" - the former is invariably false.

Besides - wasn't your problem with a PR type?
"Over the hills and far away, she prays he will return one day. As sure as the rivers reach the seas, back in his arms again she'll be." - Over the Hills and far away, Gary Moore

"So many people have come and gone, their faces fade as the years go by. Yet I still recall as I wander on, as clear as the sun in the summer sky" - More than a feeling, Boston

User avatar
blub man
Posts: 33
Joined: Tue May 09, 2006 8:50 pm

Post by blub man » Fri May 12, 2006 9:10 pm

Sorry, i got a bit caried away with how amazing i though silicon grease is! And yes it was with a PR, although i don't see how that makes any difference to the pump, but thats probably just me!
Who cares what temperature it is...GET SOAKED TODAY

Blub manImage

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sat May 13, 2006 7:05 pm

As for the part about the leak getting worse this summer, that's probably just the rubber of the O-ring drying. If that is the case, then cracking could also become a problem. I suggest actually replacing the O-ring this time, as opposed to using silicon lubricant (no offense, of course, blub man).

In addition, because Storm guns use two-stroke pumps, it might have been slightly harder to fix the seal (though this is just speculation). With standard soaker pumps, replacement O-rings have been tried and tested with success.

User avatar
blub man
Posts: 33
Joined: Tue May 09, 2006 8:50 pm

Post by blub man » Sat May 13, 2006 9:25 pm

No offense taken! ok fine change the o-rings, but pust some grease on aswell, it will help stop the o-rings wearing down again.
Who cares what temperature it is...GET SOAKED TODAY

Blub manImage

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sat May 13, 2006 10:28 pm

Well, wearing down of the rubber was definitely part of the problem, but much of it was that the rubber dried out. I know for a fact that people have complained that their (commercial, not homemade) CPS soakers had ruptured bladders, and this problem was attributed to the aging and drying out of the rubber (in the PC, not in the O-ring). Basically, the rubber could not expand--or in this case, it couldn't keep a seal--as well as it once could due to the drying effect, so it cracked instead. Maybe using silicon lubricant or a sealant, which is more convenient on O-rings than it is on CPS bladders, will seal in the moisture and prevent drying. If that is the case, then silicon lubricant is an excellent product after all.

User avatar
blub man
Posts: 33
Joined: Tue May 09, 2006 8:50 pm

Post by blub man » Sun May 14, 2006 2:09 pm

basically silicon grase stops the moisture escaping from rubber, hence stopping the rubber dry out.
Who cares what temperature it is...GET SOAKED TODAY

Blub manImage

User avatar
joannaardway
Posts: 855
Joined: Mon Feb 20, 2006 10:04 pm

Post by joannaardway » Sun May 14, 2006 3:07 pm

A pump on a PR gun will pump air - a CPS pump will pump water...

The pumps do work quite differently, but grease is always a good bet with a pump.
"Over the hills and far away, she prays he will return one day. As sure as the rivers reach the seas, back in his arms again she'll be." - Over the Hills and far away, Gary Moore

"So many people have come and gone, their faces fade as the years go by. Yet I still recall as I wander on, as clear as the sun in the summer sky" - More than a feeling, Boston

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Post by SSCBen » Sun May 14, 2006 3:18 pm

I know for a fact that people have complained that their (commercial, not homemade) CPS soakers had ruptured bladders, and this problem was attributed to the aging and drying out of the rubber (in the PC, not in the O-ring). Basically, the rubber could not expand--or in this case, it couldn't keep a seal--as well as it once could due to the drying effect, so it cracked instead.


I've never heard of this happening. Could you point out a case to me? From what I've seen, most bladders rupture from overpressurization due to a broken valve or because someone was sticking something in the chamber.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sun May 14, 2006 7:01 pm

@ blub man: I was referring to the silicon lubricant covering the O-ring and sealing in the moisture only if you spray it all over the rubber. In your case, I think it was only sprayed on the inside of the tube, unless it accidentally got on other parts of the O-ring (though it might be a bit too late for holding in the remaining moisture...).

@ Ben: I don't quite remember where I got the information about aging and drying rubber--maybe it was somewhere in the general CPS design review at iSoaker.com--but you can see this for yourself: I'm sure everybody here has played with rubber bands sometime in his or her life, or even just stretched them for some purpose; and I've noticed that quite a few of the older rubber bands have lost their rubbery feel. They don't stretch as smoothly, and they often expose cracks on the surface when stretched greatly; and worst of all, they can break very easily. That's just about the best example out there.

User avatar
blub man
Posts: 33
Joined: Tue May 09, 2006 8:50 pm

Post by blub man » Sun May 14, 2006 9:22 pm

I think we're talking about two different things here. Silicon lubricant usually comes as a spray. The stuff i'm talking about is a grease (hence: silicon grease).
Who cares what temperature it is...GET SOAKED TODAY

Blub manImage

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Post by Silence » Sun May 14, 2006 9:27 pm

Sorry about that, and thanks for pointing it out. How did you apply the grease? Did you use a swab on a string or on a stick to put it inside the pump tube, or did you just coat the O-ring?

Note: O-rings aren't that hard to obtain; my phone book's yellow pages list a category of stores that only sell O-rings. One of them must be the perfect size.

Locked