messed-up homepage

Suggestions, comments, questions, and developments related to the Super Soaker Central site and forums.
User avatar
mysterio
Posts: 142
Joined: Wed Jul 14, 2010 11:18 pm

messed-up homepage

Post by mysterio » Thu Jul 22, 2010 10:46 pm

i cant access anything but the forums. anyone else have this problem?

User avatar
zeda.beta
Posts: 683
Joined: Sun May 03, 2009 10:49 pm

Re: messed-up homepage

Post by zeda.beta » Thu Jul 22, 2010 10:47 pm

nvm, homepage just stopped loading.
I reject your reality and substitute my own.
Quack damn you.

User avatar
SEAL
Posts: 192
Joined: Sat Jul 03, 2010 2:31 pm

Re: messed-up homepage

Post by SEAL » Thu Jul 22, 2010 11:00 pm

Yeah, whenever I try to go there it just shows a blank screen.
Captain of the Catskill Mountain S.E.A.L.s (Soaker Elite Assault Legion.)

User avatar
cantab
Posts: 1492
Joined: Fri Oct 19, 2007 1:35 pm

Re: messed-up homepage

Post by cantab » Thu Jul 22, 2010 11:06 pm

Confirmed the problem.
I work on Windows. My toolbox is Linux.
Arsenal:
Super Soaker: XP215, 2xXP220, Liquidator, Aquashock Secret Strike M(odded), Arctic Blast M, CPS1200, CPS2100, SC Power Pak, 3l aquapack, 1.5l aquapack
Water Warriors: Jet, Sting Ray M, Shark, Argon M, Tiger Shark, PulseMaster
Others: Waterbolt, The Blaster, Storm 500, Shield Blaster 2000, generic PR gun, generic backpack piston pumper (broken), 3l garden sprayer M, 10l water carrier:

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: messed-up homepage

Post by SSCBen » Thu Jul 22, 2010 11:11 pm

I started investigating via MySQL in the terminal this time and I came across this:

Code: Select all

mysql> show status like 'Conn%';
+---------------+---------+
| Variable_name | Value   |
+---------------+---------+
| Connections   | 2498414 | 
+---------------+---------+
1 row in set (0.00 sec)
I think millions of connections might be a problem... I'm going to figure out how to terminate these connections.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
mysterio
Posts: 142
Joined: Wed Jul 14, 2010 11:18 pm

Re: messed-up homepage

Post by mysterio » Thu Jul 22, 2010 11:16 pm

ok, that seems like a LOT of connections. gl with that. and thanks for seeing this

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: messed-up homepage

Post by SSCBen » Thu Jul 22, 2010 11:36 pm

I don't think there's anything I can do to terminate these connections. I've informed our host of the problem and hopefully they'll terminate the connections.

This is an odd problem because it started only late last year if I recall correctly. I haven't changed any of the backend code in a while. Silence, did you change any of the code in a way that this might occur?

I'm going to look through the backend to make sure that all connections close.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Re: messed-up homepage

Post by Silence » Sat Jul 24, 2010 12:28 pm

I don't think so...I don't think I've modified any database code at all. I know I rewrote the home page around this time last year so I'll take a look at that.

For those who did encounter this problem, was it only on the home page or anywhere in the main website (http://www.sscentral.org/...)? I can't tell because things are working at the moment.

Edit: Looks like I did a bit of backend work. But what I've looked at so far looks clean, and none of it would have been executed 10,000 times a day for 300 days.
Last edited by Silence on Sat Jul 24, 2010 1:00 pm, edited 1 time in total.

User avatar
zeda.beta
Posts: 683
Joined: Sun May 03, 2009 10:49 pm

Re: messed-up homepage

Post by zeda.beta » Sat Jul 24, 2010 4:07 pm

It works now! Whatever you guys did, great job!
I reject your reality and substitute my own.
Quack damn you.

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: messed-up homepage

Post by SSCBen » Sat Jul 24, 2010 7:02 pm

The problem is almost certainly not the database. The number I posted above applies for the entire server. I did a check of processes for our account and the only process listed was the process to check what processes are being performed.

I think Silence might have fixed part of the problem, but we'll know in a few days. Let us know here or at iSoaker.net if there are any problems.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
SEAL
Posts: 192
Joined: Sat Jul 03, 2010 2:31 pm

Re: messed-up homepage

Post by SEAL » Thu Aug 05, 2010 12:30 pm

It's gone down again.
Captain of the Catskill Mountain S.E.A.L.s (Soaker Elite Assault Legion.)

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: messed-up homepage

Post by SSCBen » Thu Aug 05, 2010 1:58 pm

I can see that now. This is frustrating. I'll recode the backend this weekend to see if that has an effect.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
SEAL
Posts: 192
Joined: Sat Jul 03, 2010 2:31 pm

Re: messed-up homepage

Post by SEAL » Fri Aug 06, 2010 3:30 pm

Well, it seems to be back up again. I hope it stays that way.
Captain of the Catskill Mountain S.E.A.L.s (Soaker Elite Assault Legion.)

Fredcompany
Posts: 198
Joined: Thu May 13, 2010 7:09 pm

Re: messed-up homepage

Post by Fredcompany » Sat Aug 14, 2010 8:58 pm

It's down again at 21:57 in England. See the time of my post for the forum time.
The message I get from Google Chrome is:

"This webpage is not available.

The webpage at http://sscentral.org/ might be temporarily down or it may have moved permanently to a new web address.

More information on this error"
I'm a dude

User avatar
SEAL
Posts: 192
Joined: Sat Jul 03, 2010 2:31 pm

Re: messed-up homepage

Post by SEAL » Sat Aug 14, 2010 9:19 pm

Yeah we've confirmed the problem at iSoaker. Except with me, it just shows a blank screen. But I don't have google chrome.
Captain of the Catskill Mountain S.E.A.L.s (Soaker Elite Assault Legion.)

Locked