Avatar problems...

Suggestions, comments, questions, and developments related to the Super Soaker Central site and forums.
User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Avatar problems...

Post by Specter » Mon Jun 16, 2008 2:35 am

OK so I thought it was time for me to get an avatar. I made one in flash cs3 professional (published it as a .gif because the forum doesn't accept .swf) and uploaded it to here directly from my computer. How come it does not move/show the animation, it's only showing the last frame of the animation.

how can i get it to show the whole thing?

(yes i drew the whole thing in flash :) )
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Goldfish4209
Posts: 88
Joined: Thu Jun 05, 2008 12:45 am

Re: Avatar problems...

Post by Goldfish4209 » Mon Jun 16, 2008 12:41 pm

yes the same thing happened with my avatar, so I switched it to a still picture.

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Avatar problems...

Post by SSCBen » Mon Jun 16, 2008 12:49 pm

If you upload it to our servers with their script it will resize it and I suppose their resize function only takes the last frame of an animation. Use the avatar URL feature. You can also use any image host to host the image. Also, if you email me the image at ben at sscentral.org I'll host it directly on the server as is. As long as the scripts here don't futz with the image you should be fine, and you avoid that with the custom URL feature.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Re: Avatar problems...

Post by Silence » Mon Jun 16, 2008 2:18 pm

I'm not so sure the URL thing will work. Most forum software just copy the image at the external location into the local filesystem anyway. The best solution is to resize the image yourself with the animation, and then upload the smaller image. Currently the limit is 80x80 pixels and 19.5 kb. Maybe it was the file size that forced vBulletin to remove the animation.

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Avatar problems...

Post by SSCBen » Mon Jun 16, 2008 4:10 pm

I just checked the settings and it does say that you can upload animated avatars. It has to be some sort of problem with the upload script and it does seem to copy externally hosted avatars to the local filesystem. I suppose you'll have to upload it at a size where it won't want to resize like SilentGuy said.

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Avatar problems...

Post by Specter » Mon Jun 16, 2008 5:20 pm

oh well it said the limit was 75x75px or some number of kb , so i just made the animation 75x75 px
If i put it on my imageshack account it should be able to work, correct?
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
SSCBen
Posts: 6449
Joined: Sat Mar 22, 2003 1:00 pm

Re: Avatar problems...

Post by SSCBen » Mon Jun 16, 2008 5:39 pm

No, SilentGuy pointed out that it will just upload it here instead. The easiest way to work around this would be to find the exact location of the avatar file and replace it. I could figure that out, but I don't have access to the server's files while my laptop needs work. Send me an email at ben at sscentral.org with your resized avatar attached and I'll see what I can do once my laptop is working again. ;)

ben@sscentral.org / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Avatar problems...

Post by Specter » Mon Jun 16, 2008 5:43 pm

ok...
so which file will you need? the .swf file? because when I open the .gif file on my computer theres no animation either. I've only used flash cs3 for a couple months at school, never got to use it on my home laptop after i got it so I don't know if its the programs problem or what. :( I wish you guys could see my avatar, its so cool animated.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Avatar problems...

Post by Specter » Mon Jun 16, 2008 6:03 pm

I think I solved the problem.
I went back into Flash and checked all the publish settings and republished the .gif file. In the gif publish settings Static image was checkmarked. I'm going to re-upload the .gif to my avatar to see if it works. :)

EDIT:
ok i had to do alot of editing... but i finally got the animation to work correctly. For some reason it wasnt showing the text properly but I figured out a way to do it. It's a bit blurry but still readable. :)
Last edited by Specter on Mon Jun 16, 2008 7:17 pm, edited 1 time in total.
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Re: Avatar problems...

Post by Silence » Mon Jun 16, 2008 8:13 pm

Well, I guess we'll never know if it was the resizing or the static export (unless you do another test), but I'm glad you solved the problem.

Funnily enough, both you and Ben have avatars sized 75x75, whereas mine is 80x80. Maybe the resizer defaults to a different size than you'd have to use otherwise. Or maybe I'm somehow getting away with a different size. At any rate, my options page says 80x80 pixels, and if I go over that, maybe the resizer shrinks it down to 75x75 and displays that warning. Weird.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Avatar problems...

Post by Specter » Tue Jun 17, 2008 3:19 am

what does everyone think of my avatar? noone said anything yet. theres no images in it at all. ;)
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Re: Avatar problems...

Post by Silence » Tue Jun 17, 2008 2:11 pm

It looks fine. I especially like how the stream fades away at the end of the shot.
Specter wrote:theres no images in it at all. ;)
?

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Avatar problems...

Post by Specter » Tue Jun 17, 2008 4:39 pm

I drew all of it with the tools in Flash :)
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

User avatar
Silence
Posts: 3825
Joined: Sun Apr 09, 2006 9:01 pm

Re: Avatar problems...

Post by Silence » Tue Jun 17, 2008 8:19 pm

Oh, I see what you meant...you didn't use a picture of a CPS 2000, you just drew it by hand. I can't say I particularly like Flash (as it's not that great a programming platform), but at least it's quicker to animate frames in it than with the GIMP Animation Package.

User avatar
Specter
Posts: 474
Joined: Sun May 13, 2007 4:57 pm

Re: Avatar problems...

Post by Specter » Tue Jun 17, 2008 9:34 pm

yeah earlier in the semester we were taught how to animate with photoshop, (which is a pain in the ass btw) Then when we moved to flash I was so glad. Its ALOT easier to animate in Flash than Photoshop. Then again Flash is made for animating. The thing i like is that Flash practically does all the animating for you. :)
My "arsenal": Customizable APH, Storm 600 pistol (still haven't finished fixing this), launcher- Model:AB1.0(Decommissioned), AB1.5, soon AB 1.1(2"rebuild) maybe ill get something else in the future
My site Image My website/forum is back up and running, for the most part after it having been deleted in october

Locked