Go Back   Super Soaker Central > Water gun technology > Repairs
User Name
Password
FAQ Members List Calendar Mark Forums Read


Welcome to the SSC Forums! You are currently viewing our boards as a guest which gives you limited access. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and more. Registration is fast, simple and absolutely free so please, join our community today! If you have any problems with the registration process or your account login, please contact contact us.
Important note: The SSC forums are now in archive mode. WaterWar.net is the new online discussion board for the water gun hobby.

 
 
Thread Tools
Old 07-22-2010, 02:00 PM   #1
chaosfox97
Chaos God
 
chaosfox97's Avatar
 
Join Date: Jul 2010
Location: San Antonio, TX
Posts: 27
UserID: 2193
Default Missing Storm 750 Valve Activator

Hi, I have a Storm 750 but it stopped firing. I opened it up and the part connected to the trigger that goes back activating a push valve, which fires the gun, is broken. Here is a picture of it from a Storm 800, it's a different model, but most of the parts seem the same. The part is pointed at by an arrow, but it's underneath one of the tubes.

I was wondering if anyone knows how to make a makeshift version of this or has a broken storm gun with this part that they're willing to give me the trigger valve activator.
chaosfox97 is offline  
Old 07-22-2010, 02:04 PM   #2
cantab
Administrator
 
cantab's Avatar
 
Join Date: Oct 2007
Location: England
Posts: 1,492
UserID: 1400
Default Re: Missing Storm 750 Valve Activator

Can you not simply superglue the part together? Perhaps add some thin strips of metal on one or both sides of the join for extra strength.
__________________
I work on Windows. My toolbox is Linux.
Arsenal:
Super Soaker: XP215, 2xXP220, Liquidator, Aquashock Secret Strike M(odded), Arctic Blast M, CPS1200, CPS2100, SC Power Pak, 3l aquapack, 1.5l aquapack
Water Warriors: Jet, Sting Ray M, Shark, Argon M, Tiger Shark, PulseMaster
Others: Waterbolt, The Blaster, Storm 500, Shield Blaster 2000, generic PR gun, generic backpack piston pumper (broken), 3l garden sprayer M, 10l water carrier:
cantab is offline  
Old 07-25-2010, 01:22 PM   #3
Silence
Administrator
 
Silence's Avatar
 
Join Date: Apr 2006
Location: Cville, VA / Urbana, IL
Posts: 3,825
UserID: 576
Default Re: Missing Storm 750 Valve Activator

As explained here.

I hope you can get this piece fixed, as Storm guns are pretty precious.
__________________
Forum rules
Silence is offline  
Old 07-25-2010, 07:12 PM   #4
chaosfox97
Chaos God
 
chaosfox97's Avatar
 
Join Date: Jul 2010
Location: San Antonio, TX
Posts: 27
UserID: 2193
Default Re: Missing Storm 750 Valve Activator

Yeah, too bad I figured that out after I opened it, cut the light wires, and accidentally break the trigger valve. Could've had a V8 *bonk*
chaosfox97 is offline  
Old 02-28-2011, 04:05 PM   #5
chaosfox97
Chaos God
 
chaosfox97's Avatar
 
Join Date: Jul 2010
Location: San Antonio, TX
Posts: 27
UserID: 2193
Default Re: Missing Storm 750 Valve Activator

Well it's been a while, but I've now fixed it. What I did was replace the rubber tube from the valve to the nozzle, cut a hole in the case so I can pull the valve manually, and...
lose the case... I'm pretty sure one of my parents threw it away...
But still with out the case it seems to work pretty well, though parts have come lose a couple of times. I hope to post pictures soon.
chaosfox97 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:55 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©2003 - 2011 The Super Soaker Central project