Go Back   Super Soaker Central > Water gun technology > Repairs
User Name
Password
FAQ Members List Calendar Mark Forums Read


Welcome to the SSC Forums! You are currently viewing our boards as a guest which gives you limited access. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and more. Registration is fast, simple and absolutely free so please, join our community today! If you have any problems with the registration process or your account login, please contact contact us.
Important note: The SSC forums are now in archive mode. WaterWar.net is the new online discussion board for the water gun hobby.

 
 
Thread Tools
Old 06-09-2009, 09:02 PM   #1
BainbridgeMilita
Junior member
 
Join Date: Jun 2009
Posts: 2
UserID: 1878
Exclamation I need help!

Ok I have a Max D 3000 and 2000 and was wondering what to do sense both of them wont work . What happens is that when ever I press the triggger it stays back and then when I pump nothing comes out I am hoping for a end of the year fight and I need them fixed fast.
PLEASE HELP!
BainbridgeMilita is offline  
Old 06-09-2009, 09:20 PM   #2
cantab
Administrator
 
cantab's Avatar
 
Join Date: Oct 2007
Location: England
Posts: 1,492
UserID: 1400
Default Re: I need help!

http://www.didkovsky.com/supersoaker/index.html

Hopefully that works.
__________________
I work on Windows. My toolbox is Linux.
Arsenal:
Super Soaker: XP215, 2xXP220, Liquidator, Aquashock Secret Strike M(odded), Arctic Blast M, CPS1200, CPS2100, SC Power Pak, 3l aquapack, 1.5l aquapack
Water Warriors: Jet, Sting Ray M, Shark, Argon M, Tiger Shark, PulseMaster
Others: Waterbolt, The Blaster, Storm 500, Shield Blaster 2000, generic PR gun, generic backpack piston pumper (broken), 3l garden sprayer M, 10l water carrier:
cantab is offline  
Old 06-09-2009, 09:22 PM   #3
Ben
Founder
 
Ben's Avatar
 
Join Date: Mar 2003
Location: Maryland
Posts: 6,449
UserID: 1
Default Re: I need help!

Welcome to SSC.

To make an accurate diagnosis we're going to need more information. See this sticky thread for what information is helpful: http://forums.sscentral.org/t2227/

I believe the problem is that the Max-D valve assembly has broken in a way that prevents opening of the valve and makes the trigger stick back. cantab's linked to a general repair for when the valve sticks open, but your valve seems to be stuck shut. Opening the water gun and investigating would be a good way to see what specifically is going on and likely is the only way to repair your water guns.
__________________

[email address] / Please read this before emailing or PMing me

Do not ask me water gun questions by email or PM. Please post the question at the forum. Private questions and suggestions are welcome by PM and email. Also, I do not sell or buy water guns online.
Ben is offline  
Old 06-10-2009, 12:04 AM   #4
C-A_99
Administrator
 
C-A_99's Avatar
 
Join Date: Aug 2006
Location: MI, US
Posts: 1,502
UserID: 809
Default Re: I need help!

If the pump is behaving normally and is working correctly, then the problem would be the trigger as mentioned above. However, the typical rubber band fix may not last long, depending on how you have it setup. The setup in the link above should work well longer than if you just put the bands where the broken spring was. In some cases, you can also undo the whole Max-D mechanism and have the valve open and close directly.
__________________
HydroBrawl Water Warfare
C-A_99 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:05 AM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©2003 - 2011 The Super Soaker Central project